Solved

Custom user properties not available in filters

  • 18 February 2023
  • 4 replies
  • 74 views

Badge

I have sent custom user properties for some users. I see these properties in the “Users & Sessions” view as expected. However, they’re not available to select in filters, group-by, or anywhere on the dashboard that I can find, so I’m not sure how to analyze them.

I saw that other users had this issue recently during an incident where Heap’s system was degraded, but it looks like that incident was resolved. Do we need the same manual resolution as Ronak-Panda did earlier today?

Thanks!
Ryan @ Userfront

icon

Best answer by dan 24 February 2023, 18:31

View original

4 replies

Userlevel 3
Badge +3

I have the same issue.

Badge

We have the same issue too!

Userlevel 1
Badge +1

Hi there, by now everything should be populating correctly and the issue resolved, but for some accounts that have relatively low volume support may need to manually restart the process that populates the dropdowns. Also it seems if new user properties are added that can resolve the visibility as well. Worth checking out if it’s resolved for you now!

Badge

Hey Ryan!

Happy to provide some guidance on this. A little while ago we unfortunately experienced an issue wherein new User Properties sent in via the API would be captured but wouldn’t populate in either the Definitions tab or the Dropdown lists across your reports.

 

This has since been resolved, though any user properties sent in during the downtime may still not appear. To resolve this, please try sending in the property again where it should update correctly. Just to reiterate, no data capture was affected here - just the property lists in the UI.

 

If you’re still experiencing this issue please let us know and we’ll be happy to help!

 

Dan | Solutions Engineer @ www.heap.io

Reply